2003, № 12 · ИНФОРМАТИКА И ТЕЛЕКОММУНИКАЦИИ
Сервисы GRID, как объекты стандартизации
1 ИРЭ им. В.А. Котельникова РАН, Москва, Россия
Аннотация
Обобщен мировой опыт по созданию и применению GRID, приведены основные понятия и определения, выявлены основные проблемы по реализации GRID-технологий, в том числе построение архитектуры GRID, проведена классификация сервисов, рассмотрены вопросы безопасности GRID. Показана необходимость реализации принципов открытых систем.
Для цитирования
Каменщиков М.А. Сервисы GRID, как объекты стандартизации // Журнал радиоэлектроники. – 2003. – № 12.
Литература
- Johnston, W.E., Gannon, D. and Nitzberg, B., GRIDs as Production Computing Environments: The Engineering Aspects of NASA's Information Power GRID. In Proc. 8th IEEE Symposium on High Performance Distributed Computing, 1999, IEEE Press.
- Chervenak, A., Foster, I., Kesselman, C., Salisbury, C. and Tuecke, S. The Data GRID: Towards an Architecture for the Distributed Management and Analysis of Large Scientific Data Sets. J. Network and Computer Applications, 2001
- Childers, L., Disz, T., Olson, R., Papka, M.E., Stevens, R. and Udeshi, T. Access GRID: Immersive Group-to-Group Collaborative Visualization. In Proc. 4th International Immersive Projection Technology Workshop, 2000.
- Clarke, I., Sandberg, O., Wiley, B. and Hong, T.W., Freenet: A Distributed Anonymous Information Storage and Retrieval System. In ICSI Workshop on Design Issues in Anonymity and Unobservability, 1999
- Czajkowski, K., Fitzgerald, S., Foster, I. and Kesselman, C. GRID Information Services for Distributed Resource Sharing, 2001.
- Realizing the Information Future: The Internet and Beyond. National Academy Press, 1994. http://www.nap.edu/readingroom/books/rtif/.
- Tierney, B., Johnston, W., Lee, J. and Hoo, G. Performance Analysis in High-Speed Wide Area IP over ATM Networks: Top-to-Bottom End-to-End Monitoring. IEEE Networking, 1996.
- Beynon, M., Ferreira, R., Kurc, T., Sussman, A. and Saltz, J., DataCutter: Middleware for Filtering Very Large Scientific Datasets on Archival Storage Systems. In Proc. 8th Goddard Conference on Mass Storage Systems and Technologies/17th IEEE Symposium on Mass Storage Systems, 2000, 119-133.
- Butler, R., Engert, D., Foster, I., Kesselman, C., Tuecke, S., Volmer, J. and Welch, V. Design and Deployment of a National-Scale Authentication Infrastructure. IEEE Computer, 33(12):60-66. 2000.
- Foster, I., Kesselman, C., Tsudik, G. and Tuecke, S. A Security Architecture for Computational GRIDs. In ACM Conference on Computers and Security, 1998, 83-91.
- Gasser, M. and McDermott, E., An Architecture for Practical Delegation in a Distributed System. In Proc. 1990 IEEE Symposium on Research in Security and Privacy, 1990, IEEE Press, 20-30.
- Howell, J. and Kotz, D., End-to-End Authorization. In Proc. 2000 Symposium on Operating Systems Design and Implementation, 2000, USENIX Association. The Anatomy of the GRID 24
- Berman, F. High-Performance Schedulers. In Foster, I. and Kesselman, C. eds. The GRID: Blueprint for a New Computing Infrastructure, Morgan Kaufmann, 1999, 279-309. The Anatomy of the GRID 22
- Berman, F., Wolski, R., Figueira, S., Schopf, J. and Shao, G. Application-Level Scheduling on Distributed Heterogeneous Networks. In Proc. Supercomputing '96, 1996.
- Frey, J., Foster, I., Livny, M., Tannenbaum, T. and Tuecke, S. Condor-G: A Computation Management Agent for Multi-Institutional GRIDs, University of Wisconsin Madison, 2001.
- Abramson, D., Sosic, R., Giddy, J. and Hall, B. Nimrod: A Tool for Performing Parameterized Simulations Using Distributed Workstations. In Proc. 4th IEEE Symp. on High Performance Distributed Computing, 1995.
- Beiriger, J., Johnson, W., Bivens, H., Humphreys, S. and Rhea, R., Constructing the ASCI GRID. In Proc. 9th IEEE Symposium on High Performance Distributed Computing, 2000, IEEE Press.
- Allcock, B., Bester, J., Bresnahan, J., Chervenak, A.L., Foster, I., Kesselman, C., Meder, S., Nefedova, V., Quesnel, D. and Tuecke, S., Secure, Efficient Data Transport and Replica Management for High-Performance Data-Intensive Computing. In Mass Storage Conference, 2001
- Hoschek, W., Jaen-Martinez, J., Samar, A., Stockinger, H. and Stockinger, K., Data Management in an International Data GRID Project. In Proc. 1st IEEE/ACM International Workshop on GRID Computing, 2000, Springer Verlag Press.
- Casanova, H. and Dongarra, J. NetSolve: A Network Server for Solving Computational Science Problems. International Journal of Supercomputer Applications and High Performance Computing, 11(3):212-223. 1997.
- Nakada, H., Sato, M. and Sekiguchi, S. Design and Implementations of Ninf: towards a Global Computing Infrastructure. Future Generation Computing Systems, 1999.
- DeFanti, T. and Stevens, R. Teleimmersion. In Foster, I. and Kesselman, C. eds. The GRID: Blueprint for a New Computing Infrastructure, Morgan Kaufmann, 1999, 131-155. The Anatomy of the GRID 23
- Leigh, J., Johnson, A. and DeFanti, T.A. CAVERN: A Distributed Architecture for Supporting Scalable Persistence and Interoperability in Collaborative Virtual Environments. Virtual Reality: Research, Development and Applications, 2(2):217-237. 1997.
- Foster, I. and Karonis, N. A GRID-Enabled MPI: Message Passing in Heterogeneous Distributed Computing Systems. In Proc. SC'98, 1998.
- Gabriel, E., Resch, M., Beisel, T. and Keller, R. Distributed Computing in a Heterogeneous Computing Environment. In Proc. EuroPVM/MPI'98, 1998.
- Casanova, H., Obertelli, G., Berman, F. and Wolski, R., The AppLeS Parameter Sweep Template: User-Level Middleware for the GRID. In Proc. SC'2000, 2000.
- Goux, J.-P., Kulkarni, S., Linderoth, J. and Yoder, M., An Enabling Framework for Master-Worker Applications on the Computational GRID. In Proc. 9th IEEE Symp. on High Performance Distributed Computing, 2000, IEEE Press.
- I Foster,C Kesselman, S Tuecke, The Anatomy of the GRID; Enabling Scalable Virtual Organisations; 2001
- Kohl, J. and C. Neuman, "The Kerberos Network Authentication Service (V5)", RFC 1510, September 1993.
- Dierks, T. and C. Allen, "The TLS Protocol, Version 1.0", RFC 2246, January 1999.
- Arsenault, A. and S. Turner, "Internet X.509 Public Key Infrastructure, PKIX Roadmap", Internet Draft, March 10 2000.
- Housley, R., "Cryptographic Message Syntax", RFC 2630, June 1999
- Linn, J., "Generic Security Service Application Program Interface, Version 2, Update 1", RFC 2743, January 2000.
- Wray, J., "Generic Security Service API Version 2, C-bindings", RFC 2744, January 2000.
- Adams, C., "Independent Data Unit Protection Generic Security Service Application Program Interface (IDUP-GSS_API", RFC 2479, December 1998.
- Владимир Галатенко, Информационная безопасность - обзор основных положений Открытые Системы # 3 1996
- Владимир Галатенко, Информационная безопасность, Открытые Системы # 4 1996
- Илья Трифаленков, Система информационной безопасности на основе ОС Solaris, Открытые Системы # 3 1996
- Н. Вьюкова, Hесанкционированный доступ - примеры вторжения, Открытые Системы # 1 1996
- Беляев В.И. Безопасность в распределенных системах, Открытые Системы # 3 1995
- Зегжда Д.П., А.М. Ивашко Основы информационной безопасности, Москва Горячая линия-Телеком 2000